Tools required to develop PhoneGap / Cordova App

This article shares the system requirements and list of tools required to develop a Hybrid Mobile App using Cordova/PhoneGap.


PhoneGap framework : http://phonegap.com/
Or Cordova framework : http://cordova.apache.org/

Get details about Installing PhoneGap on Windows Machine here, as the process includes installation of many required libraries which are not mentioned in the PhoneGap Website.

System and tools required for Android build :

System :             – Windows XP (32-bit), Vista (32- or 64-bit), or Windows 7 (32- or 64-bit)
                          – Mac OS X 10.5.8 or later (x86 only)
                          – Linux (tested on Ubuntu Linux, Lucid Lynx)
                                GNU C Library (glibc) 2.7 or later is required.
                                On Ubuntu Linux, version 8.04 or later is required.
                                64-bit distributions must be capable of running 32-bit applications.
SDK :                 Android SDK
IDE :                  Eclipse
Device :             Android Mobile, Tablet

System and tools required for Windows build : 

System :            Windows 8 64-bit (x64), Mac
IDE :                  Visual Studio Express 2012 for Windows Phone [Included in SDK]
SDK :                 Windows Phone SDK
Device :             Window 8 Mobile, Tablet

System and tools required for iOS build : 

System :            Mac OS X 10.7 (Lion) or later
IDE :                  Xcode
SDK :                 iOS SDK [included with IDE]
Device :             iOS Mobile, Tablet

PhoneGap V3.0 and later includes a CLI (Command Line Interface) that provides a suite of commands a developer can use to manage the complete lifecycle of an application.
Get details of using PhoneGap/Cordova CLI here.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.